[osg-users] Having an issue with OSG plugins error.

Alberto Luaces aluaces at udc.es
Wed Apr 12 00:35:58 PDT 2017

"Brigham Keys, Esq."  writes:

> Hello all,
> I have OpenSceneGraph set up in my project, however when I try to load
> any files I always get this error
> Error reading file build/untitled.osgt: read error (Could not find
> plugin to read objects from file "build/untitled.osgt".)
> Which I did not think I needed a plugin set up for the native format,
> it does this on .obj and on .dae parsing as well and the 3D model
> never gets loaded into the scene. I tried doing this with files that
> could not possibly be real and it gives me the exact same error (and
> not an error relating to the file not existing). Has anyone else
> experienced this issue?

Hi Brigham, this error could be caused by your system not finding the
plugin directory, or when it holds a different version of the plugins
(debug/release, any other version...)


More information about the osg-users mailing list