[osg-users] Cannot render and load OBJ when using QOpenGLWidget with osgViewer::GraphicsWindowEmbedded on OSG 3.5.6 rc2 and 3.6.4

OpenSceneGraph Users osg-users at lists.openscenegraph.org
Thu Jan 30 03:47:24 PST 2020

When using *QOpenGLWidget *with *osgViewer::GraphicsWindowEmbedded *to 
render and load *OBJ *file nothing is being rendered, I am using latest osg 
3.6.5 rc2 on ubuntu 19.10 with Inel graphics Card hd 620 using Mesa 19.3. 
When I create a passive osgViewer::GraphicsWindowEmbedded along 
QOpenGLWidget to render any geometrical shapes using normal 
osg::ShapeDrawable and osg Geode and it works fine, if I use 
osgDB::readNodeFile instead to load mesh objects using STL formats it works 
fine, but if I opt for OBJ format, it won't render anything I am attaching 
a working example 

I am extending a QOpenGLWidget using... class QtOSGWidget : public 
QOpenGLWidget and ovveriding necessary virtual functions and having normal 
passive osg embedded viewer withing QOpenGLWidget. The strange thing this 
workflow works for me without a problem on windows 10, what's more stranger 
if I opt for normal osgViewer::Viewer without the Qt QOpenGLWidget it works 
fine and loads and renders the obj file perfectly.

I've attached debug output of osg using OSG_NOTIFY_LEVEL set to DEBUG. I am 
using Qt 5.14 and I also tried Qt 5.12, 5.9 and 5.7 and I got the same 
Also using Qt Creator 4.11, also I discovered that when I launch the 
application using the debugger right from Qt creator I would be able to 
render it normally, if I launch the application normally without Qt 
creator's debugger nothing is rendered, same result with release and debug 
and also launching application from bash cmd line.

I would like to draw the attention to the fact that the OBJ sounds normal 
tried it with osg 3.6.5 rc2 and 3.6.4 on windows and above scenario works 
fine, no problem with location obj file or anything like that. I believe 
that the problem is coupled only with QOpenGLWidget and 
osgViewer::GraphicsWindowEmbedded to load OBJ file(only) on linux (ubuntu 
19.10, xubunu 18.10).

You received this message because you are subscribed to the Google Groups "OpenSceneGraph Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to osg-users+unsubscribe at googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/osg-users/43a9d8de-b692-4046-bb9f-3645cae0204c%40googlegroups.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20200130/1e2de8a6/attachment.html>

More information about the osg-users mailing list