[osg-users] OS X (10.9) Texture2D with hardware compression results in no texture data.

David Guthrie dguthrie at alionscience.com
Thu May 28 06:52:46 PDT 2015

Hello everyone,

I started upgrading delta3d to use osg 3.3.x, but I ran into a strange problem that that seems like it must be something that changed in the osg::Texture code, thought it only manifests on OS X.  The texture is setting compressed mode, I think it turns on mip mapping correctly, and it ends up calling extensions->glCompressedTexSubImage2D().  

The only reason I think it has to be in this code, is that I tried it with an ive file that has compressed textures.  Those load straight into the image object from the ive file, and into the Texture2D.

I can export the textures from the ive, and read them in an image tool, and I can load the ive and works fine on Windows.  In case you get the wrong idea, I have an application with many different file formats and both extrernal and embedded textures.  Not a single compressed image we have will load properly on OS X, but they all work on in OSG 3.2.1.  

Any thoughts would be appreciated!


Read this topic online here:

More information about the osg-users mailing list