[osg-users] [build] Question about method of building osgQt

Tim Whowantstoknow Tare.noN at web.de
Fri May 24 02:31:38 PDT 2019

I ran into the same problem. I tried around a bit, and I got it to generate solution files with cmake.

First, open the CMakeLists.txt in the osgQt and edit line 95 and remove the "3.6.0" version number.

The result is then

FIND_PACKAGE(OpenSceneGraph REQUIRED osgDB osgGA osgUtil osgText osgViewer osgWidget)

Then configure everything in cmake and generate it. Even if you still get the error (I think I had it in the GUI when using configure, but not when using generate), it should generate the Visual Studio files (I was going for VS2017, so ymmv).

When I tried to compile, it didn't work though. This may have been a wrong setup on my side, but the include paths where absolute paths to the osgDB, osgGA, osgUtil, ... submoduls, rather than having only OpenSceneGraphs include file. 

Having changed that, I end up with a few errors of 

> C4430 missing type specifier - int assumed. Note: C++ does not support default-int


> C2146 syntax error: missing '>' before identifier 'GLFloat'

in the file GL, as well as

> C2065 'GLenum': undeclared identifier

in the file qopenglext.h

Usually this indicates that your project lacks the 
#include windows.h

 (this should be <windows.h>, but the forum somehow doesn't display that correctly) line, however that is obviously only for windows and I have tried including it in the osgQOpenGLWindow file, and that did not work. I will try a bit more and post, if I find the solution to that last problem

Read this topic online here:

More information about the osg-users mailing list