[osg-users] [osgPlugins] Problems with dae plugin

Nikita Petrov nikitapetroff at gmail.com
Mon Apr 8 08:51:16 PDT 2019


I am trying to build dae plugin to open dae files with osgviewer.
Everything builds great, but when I try to open dae file (I tried several) I get the following error:

Error reading file .\test.dae: read error (Could not find plugin to read objects from file ".\test.dae".)

I use stable OSG tags/3.6.3.
Windows 10 x64.
Visual Studio 2015 Update 3.
Almost all 3rdParty dependencies are built with vcpkg. GDAL, tiff, proj.4, geotiff are built from sources.

For Collada-dom library I tried 2 options:

- use vcpkg to build collada-dom (built DLL filename: collada-dom2.5-dp-vc130-mt.dll).
- build collada-dom from sources (built DLL filename: collada-dom2.5-dp-vc100-mt.dll).

I copied the collada DLL to OSG bin folder.

Is it possible that dae plugin is broken? What am I doing wrong?

Thank you!

Best regards,

Read this topic online here:

More information about the osg-users mailing list