[osg-users] GLES link error for unidentified Program

Alessandro Terenzi a.terenzi at gmail.com
Thu Jan 25 10:05:27 PST 2018

I did some more tests, tried to remove that 'program' from StateSet::setGlobalDefaults () and I realised that, at last, that very program is really not tried to be linked at all (it looks like the attached shaders are not even compiled, but I'm not 100% sure). 

So, I cannot say that the error comes from that 'program' in StateSet::setGlobalDefaults(), also because I tried to print the addresses of the 'program's being linked and I cannot track the origin of the one that fails to link...I also tried to get its attached shaders during the application loop but none is really attached to that program (calling getNumShaders() returns 0 on the 'program' that is not linked).

I think that what I am missing is a deeper understanding about what happens beyond the setup of the simple scene graph that I explicitly do with my code. Is there the possibility that OSG automatically creates a 'program' somewhere else beyond my explicit code? Any suggestion where to look? I tried to search for strings like "new osg::Program" or "getOrCreateProgram" but could not figure out anything yet...


Read this topic online here:

More information about the osg-users mailing list