[osg-users] Texture2DArray Internal Texture Format (OSG3.4.0)

Tim Whowantstoknow Tare.noN at web.de
Wed Apr 4 03:35:50 PDT 2018


since I couldn't get 3.6.0 rc2 to run, I have been working with 3.4.0, so I'm not sure if this is happening in the current version.

I have been trying out Texture2DArrays and have loaded in 16 images, set them to a Texture2Array object and tried to display it. When calling frame the first time, I got some warnings:
"Warning: Texture2DArray::applyTexImage2DArray_subload(..) given image do have wrong dimension or internal format."
None of the loaded images is displayed as a texture.
I have debugged into the OSG Code to look for the error, and it turns out, that upon loading (a bmp file for every texture, all have the same width and height), the internal texture format of the images is set to 3 (which is GL_RGB at some point of the code), but the Texture2DArray internal format is 6407, which is also GL_RGB. 

I went on to set the image internal texture format to GL_RGB (which in this case is 6407) and now it works.

I'd add a minimal working example, but the forum seems to not let me do that, so sorry about that.

Read this topic online here:

More information about the osg-users mailing list