[osg-users] OpenSceneGraph-3.5.9 developer release tagged

Robert Osfield robert.osfield at gmail.com
Thu Nov 30 12:30:40 PST 2017

Hi Jordi,

On 30 November 2017 at 20:11, Jordi Torres <jtorresfabra at gmail.com> wrote:
> No I don't have this dependency in my system, fresh build. In fact
> OPENCASCADE_TKDCAF is part from the package oce-draw, so CMake does not find
> it automatically. But OPENCASCADE_TKVCAF is definitely not there.

I don't understand the what specifically happening on your system, the
FindOpenCascade script is long winded, I can only guess that some
combination of dependencies on your system are causing an issue.

> Can you tell me what packages do you have installed w.r.t opencascade? Maybe
> a newer version?

It's a year since I worked on the OpenCascade so I'm a bit rusty.
Looking at where it's installed on my system it's in
/usr/local/include/opencascade and /usr/local/lib so I probably
installed from a local install/build rather than pulling it in from
debian/ubuntu repositories.

> BTW Is probable that we don't need all the libraries here:
> https://github.com/openscenegraph/OpenSceneGraph/blob/master/CMakeModules/FindOpenCascade.cmake#L57-L112
> to build the plugin.

OpenCascade requires an massive number of separate libs to do even
basic things with it, I tried to keep the number down as much as I
possible could.  It was one of these tasks that at the start looked to
be a straight forward but ended up a bit of nightmare to get things
linking, lib after lib had to be added.

I'm pretty sure we can't cut down the number of libs that are linked
in.  Whether we can cut down the number of Find's I don't know.  It's
a whole heap of stuff to iterate through to find out the minimum

As to what is wrong with the FidOpenCascade script in your case I
don't know.  Could it be finding a subset of all the libs but not all
of them but is still assuming that it can build the plugin?


More information about the osg-users mailing list