[osg-users] Failed to build openscenegraph on Alpine

Roberto Oliveira rdutra at linux.vnet.ibm.com
Mon Jun 26 14:54:45 PDT 2017


The build worked fine in Alpine Linux x86_64, but when I tried to buid 
in Alpine Linux ppc64le, I got the following error:

error: #error "Qt version mismatch detected! Make sure to compile 
applications using osgQt with the same major Qt version that osgQt has 
been compiled against."

In both Alpine x86_64 and ppc64le qt 4.8.7 is the available version.

Any clue why it is failing?

Roberto Oliveira

On 06/26/2017 04:49 PM, Roberto Oliveira wrote:
> With this patch my build now works, Thanks a lot!
> On 06/26/2017 01:24 PM, Alberto Luaces wrote:
>> Alberto Luaces writes:
>>> Roberto Oliveira writes:
>>>> The openscenegraph needs a specific version of ffmpeg to compile or am
>>>> I missing something?
>>> Yes, that issue seems to be currently fixed in master.
>> ...and maybe this patch is useful for you if you want to stick with 3.4:
>> https://anonscm.debian.org/cgit/pkg-osg/openscenegraph-3.4.git/tree/debian/patches/ffmpeg_2.9.patch 
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

More information about the osg-users mailing list