[osg-users] ReadImage not routing to plugin?

Robert Osfield robert.osfield at gmail.com
Sat Sep 24 08:20:10 PDT 2016

Hi Rob,

osgmovie requires you to explictly preload the plugin if you don't use
the .ffmpeg suffix try:

    osgmovie -e ffmpeg mymovie.qqq

This will load the plugin with the extension/name ffmpeg.


On 23 September 2016 at 23:30, Rob Spearman <rob at digitaliseducation.com> wrote:
> Thanks for the comments, Robert.  Those match my understanding of how the
> plugins are supposed to work, so I am still stumped.
> As a simple example, I have a video file which I have named test.qqq to
> avoid any question of other plugins getting involved.
> I modified the ffmpeg plugin to advertise that it can handle this extension
> via supportsExtension("qqq") and the Registry method addFileExtensionAlias(
> "qqq", "ffmpeg").
> When I run "osgmovie test.qqq.ffmpeg" I see the movie play.
> When I run "osgmovie test.qqq" I get an error:  "Could not find plugin to
> read objects from file"
> Loading the ffmpeg plugin explicitly via the Registry loadLibrary("ffmpeg")
> method doesn't make any difference.
> I am not seeing why the Registry is not working as expected.  I'm on Linux.
> Thanks,
> Rob
> _______________________________________________
> osg-users mailing list
> osg-users at lists.openscenegraph.org
> http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

More information about the osg-users mailing list