[osg-users] [osgPlugins] Conflict between OSG and Qt

Joseph Mirabel josephmirabel at gmail.com
Mon Mar 21 08:34:14 PDT 2016

Thanks for your quick reply.

The same behavior happens on many different models. For instance, base.dae in https://github.com/PR2/pr2_common/tree/indigo-devel/pr2_description/meshes/base_v0.

The STL models, iin the previous link, are rendered fine. I haven't tried any other formats. 

I got slightly confused. I have two different integration of OSG in Qt:
- The first one is the OSG examples. With DAE models, it renders an empty scene (I tried pressing the space bar),
- The second version is a bit messy as it is not really a unit test. It is located here: https://github.com/jmirabel/hpp-gui/blob/devel/include/hpp/gui/osgwidget.hh and https://github.com/jmirabel/hpp-gui/blob/devel/src/osgwidget.cc. With DAE models, it renders black triangles as in the screenshot.

The problem happens on version 3.2 and 3.4.

On another computer which I do not have at hand now, I was able to display DAE by first converting them to the OSG format using osgconv and then viewing the converted file. But my current computer, I get the same result as in the screenshot.

Thank you!


Read this topic online here:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screenshot - 21032016 - 16_01_06.png
Type: image/png
Size: 67335 bytes
Desc: not available
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20160321/1eb1bdbd/attachment-0003.png>

More information about the osg-users mailing list