[osg-users] Android osgPlugins

Christian Kehl christian-kehl at web.de
Mon May 25 02:10:21 PDT 2015


I still didn't get it to work. I spoke with an Android developer the recent days, told him the problem. His suggestion: move the requested library files in the libs-folder of your project, which is how the Android jni usually works. Said and done, I created a folder in osgSimple called "libs" and copied the OpenSceneGraph 3.3.8 library files (static libraries) into the "libs" folder. Unfortunately, I still get the same error, the app searches for the dynamic library (at least according to LogCat). Any further ideas ? I can still try a dynamic compile of OSG 3.3.8 and compile osgAndroid from there on again, but I don't know how promising that may be. Thing is: the osgAndroid compile itself is fine because the gray render window is created. It is just that the plugins are not found by the Android system ...

Thank you!


Read this topic online here:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: library_folder.png
Type: image/png
Size: 82455 bytes
Desc: not available
URL: <http://lists.openscenegraph.org/pipermail/osg-users-openscenegraph.org/attachments/20150525/506f1ace/attachment-0003.png>

More information about the osg-users mailing list