[osg-users] [osgPlugins] DESPERATE!! Tried everything to get JPEGS TO LOAD!

Jan Ciger jan.ciger at gmail.com
Sat May 16 04:52:45 PDT 2015

Hash: SHA1

On 05/12/2015 07:58 PM, Gregory Basile wrote:
> Hello all,
> I built osg version 3.3.1 for visual studio 2013 on windows 8.1.
> I've tried every suggestion on this forum to try to get jpegs to
> load. I have osgdb_jpeg.dll and osgdb_jpegd.dll in the bin folder,
> paths are set up correctly, rebuilt multiple times just to be sure.
> I ran dependancy walker on OSGDB_jpeg.dll and got a few errors
> relating to microsoft system files, but I do not know what they
> really mean, or how to fix it. Screen caps attached.
> ...

There is little we can tell you from that screenshot, because it lacks
information. The error you are getting usually stems either from the
fact that OSG is unable to find the required plugin to load the data
file at runtime or that the plugin didn't load correctly (bad DLL,
bad/missing dependency of that plugin DLL, etc.)

Generally, Dependency walker complaining about dependencies of
Microsoft's DLLs (OpenGL32.dll in this case) is a red herring - those
messages you can ignore.

However, one message stands out in that Dependency walker - "Modules
with different CPU types found".

That means that you are mixing 32bit and 64bit DLLs in one program.
That is not allowed and will not work. Unfortunately Windows is
severely retarded in this regard and will happily load a 32bit DLL
into a 64bit program, only to crash later. E.g. Linux will complain
right away that it didn't find the correct DLL/shared library even if
the one for the wrong architecture is available.

Did you use 32bit dependencies (libjpeg) to with a 64bit version of OSG?


Version: GnuPG v1


More information about the osg-users mailing list